Retroarch Emulation Thread (Nightly Builds Included)

Discussion in '3DS - Homebrew Development and Emulators' started by Slasher115, Oct 26, 2015.

  1. lone_wolf323

    lone_wolf323 GBAtemp Advanced Fan

    Member
    931
    321
    May 27, 2011
    Canada
    Hellos. was wondering how I would set up gameshark codes to work on gambatte. Been looking but the setups used just end up with gambatte crashing.
     
  2. Smoker1

    Smoker1 GBAtemp Maniac

    Member
    1,298
    222
    Feb 17, 2015
    United States
    Carmichael, California
    There is a RetroArch Cheat Collection somewhere on their Official Page I think. Got all of them and they work. Just wish there were Codes for the FBA Cores that would work with it. RA only uses .cht Files, and the FBA Codes are .ini Files.
    Anyone else getting System Crashes with RA when looking for Games to run?
    Using 1.7.0 now, even happened with previous Builds. Have a 128GB MicroSD. Games work perfectly.
    I Start a Core, go to Load Content, start looking through my Files......Crash.
     
  3. FateForWindows

    FateForWindows GBAtemp Advanced Fan

    Member
    706
    255
    Feb 8, 2017
    United States
    Is the menu driver set to XMB or rgui? Right now with XMB pressing down can cause a crash.
     
  4. Smoker1

    Smoker1 GBAtemp Maniac

    Member
    1,298
    222
    Feb 17, 2015
    United States
    Carmichael, California
    No. Normal Driver. Rgui
     
  5. FateForWindows

    FateForWindows GBAtemp Advanced Fan

    Member
    706
    255
    Feb 8, 2017
    United States
    As in the plain menu or the one that looks like a PS3?
     
  6. Smoker1

    Smoker1 GBAtemp Maniac

    Member
    1,298
    222
    Feb 17, 2015
    United States
    Carmichael, California
    Plain Menu. No Dynamic or the Background that looks like the PS3. Just the simple, plain Background.

    The 128GB Card, I had to use EaseUS Partition to get it to the right Format. Had to Apply the Image of my 64GB Card to it, then Extend the Partition to utilize the full Card.
     
  7. FateForWindows

    FateForWindows GBAtemp Advanced Fan

    Member
    706
    255
    Feb 8, 2017
    United States
    Try manually selecting them as a temporary solution.
     
  8. AMDZen

    AMDZen Member

    Newcomer
    19
    2
    Aug 20, 2008
    United States
    I couldn't figure out how to change it from XMB myself before it crashed so FYI if you run into the same thing, go into the retroarch.cfg file and change the menu_driver to "rgui" and save the cfg file then it should work

    Also I was able to find this for a cheat file thats compiled but I have yet to try it out

    buildbot.libretro.com/assets/frontend/cheats.zip
     
    Last edited by AMDZen, Dec 29, 2017
    Smoker1 likes this.
  9. Smoker1

    Smoker1 GBAtemp Maniac

    Member
    1,298
    222
    Feb 17, 2015
    United States
    Carmichael, California
    Works perfectly now :D
     
  10. MightyJAK

    MightyJAK Member

    Newcomer
    13
    8
    Mar 13, 2014
    United States
    You can reduce the lag in some games by loading them in unscaled 1:1 pixel mode (hold start or select). At least for me, the lag reduction was noticeable in Mario Kart Super Circuit.
     
  11. dsearnack

    dsearnack Member

    Newcomer
    35
    3
    Nov 25, 2017
    United States
    Hello all! I am on version 1.7.0 and came from 1.6.7 -- I have been looking for the cause/fix to my problem and was hoping you all could help.

    When using the dosbox core I would always select "Mapper" as the input - and after updating to 1.7.0 I no longer see this as an option however...

    The input information seems to be somewhat there. I see "Unknown" as the input with all the info about the "mapper" controls
    However when I go into options I see the normal CPU options and no options for changing the mapper buttons like there once was.

    How do I return this Mapper input?
     
  12. trecko1234

    trecko1234 Advanced Member

    Newcomer
    69
    35
    Aug 10, 2013
    United States
    Try manually setting the input to 'mapper' in the .cfg file? Shot in the dark but it's worth a try.

    If that still doesnt work try updating to the latest nightly and see if it maybe got fixed since the last release.
     
    Last edited by trecko1234, Dec 30, 2017
  13. dsearnack

    dsearnack Member

    Newcomer
    35
    3
    Nov 25, 2017
    United States
    retroarch.cfg file? and you'd think that it may show "unknown" somewhere in there so that I can update that line to "mapper" but the FIND tool says its not there haha. Currently deleting all files and transferring retroarch back to SD (instead of over writing them as I first did)
     
  14. trecko1234

    trecko1234 Advanced Member

    Newcomer
    69
    35
    Aug 10, 2013
    United States
    Yes, since its showing unknown it means that it doesn't know what it is so you'd have to find the input line and manually change the value to "mapper" because "unknown" isnt a real value. I'm not sure what it is off the top of my head and i've never used DOSbox on retroarch before so I wouldn't know what im looking for.

    Try reverting back to retroarch 1.6.7 and then searching the retroarch.cfg file for "mapper" if doing a clean install of retroarch 1.7.0 didn't work. Then you can find what setting it's stored as and copy it to the 1.7.0 cfg
     
  15. dsearnack

    dsearnack Member

    Newcomer
    35
    3
    Nov 25, 2017
    United States
    Thought about the config for 1.6.7 (have it backed up on laptop) searching that config returned the same, no mapper found.

    Also Mapper is one of the generic options in 1.6.7 so you may be on to something that was forgotten, my only current options are "gamepad" "joystick" "keyboard" after the fresh 1.7 install

    Currently going to nightly to test
     
  16. dsearnack

    dsearnack Member

    Newcomer
    35
    3
    Nov 25, 2017
    United States
    went back to 1.6.7 and no issues
    nightly and 1.7 from 12/26 both are missing the mapper input
    Will the config for 1.6.7 work in a 1.7 environment? and are their variables I would need to add to the config?
    ^^ trying this now^^

    Tried the config with 1.7 files tried 1.7 cias with 1.6 folders no option but a full 1.6.7 shows the mapper - strange
     
    Last edited by dsearnack, Dec 30, 2017
  17. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    7,558
    5,075
    Jan 17, 2013
    Mexico
    Been out of the loop for RA on the 3DS since the 1.3.6 versions.
    How stable are the latest nightlies? I've read about some issues but I don't want to update the cores I have installed until someone can tell me if the latest are safe
     
  18. trecko1234

    trecko1234 Advanced Member

    Newcomer
    69
    35
    Aug 10, 2013
    United States
    Have you tried like... reading back in this thread a few pages first?
     
  19. guicrith

    guicrith Member

    Newcomer
    25
    18
    Apr 29, 2013
    United States
    They are perfectly fine, you just have to use rgui instead of xmb for now.
    The 3ds port isnt dead anymore, check the commit history I have fixed a few major bugs and for those who dont know new ROMs are still getting released today and old emu versions wont support there mappers so old versions limit your ROM selection.

    So just update, xmb will be fixed in time and cheevos support is almost ready.
     
    dsearnack, Fatalanus and ShadowOne333 like this.
  20. Palom

    Palom GBAtemp Regular

    Member
    166
    23
    Sep 21, 2009
    United States
    Would it be possible for the rgui version of the Load Content menu to not have "Favorites/Image/Music" on there? Or at least move "Start directory" to the top? This issue is what's keeping me on 1.4.1.
     

    Attached Files:

    Last edited by Palom, Dec 30, 2017
    SaffronXL likes this.