Ubuntu VM with Pegaswitch Libtransistor and RetroArch PreConfigured

Discussion in 'Switch - Hacking & Homebrew' started by yardie, Nov 19, 2017.

  1. yardie
    OP

    yardie GBAtemp Advanced Fan

    Member
    919
    951
    Mar 27, 2016
    United States
    New scripts updated to include NES, GBA emulators
    Easily select the option you want to start building. Remember to put your roms in the RetroArch/fs folder before running the buildretro script

    The first script:
    • removes and rebuilds libtransistor, snes9x, vba-next and fceumm from their github sources
    • creates fs directory
    The second script:
    • make-cleans the retroarch folder
    • prompts you to select which emulator you want to build for
    • copies the respective libretro_switch.a to the RetroArch folder and builds the emulator .nro file
     

    Attached Files:

    Last edited by yardie, Jan 13, 2018
    Greg956 and seanp2500 like this.
  2. urherenow

    urherenow GBAtemp Psycho!

    Member
    3,087
    938
    Mar 8, 2009
    United States
    Japan
    umm... it's already part of libtransistor? If you need to update it:

    cd /path/to/libtransistor/projects/ace_loader
    git pull origin master
    make clean && make LLVM_POSTFIX=-5.0

    If you want half of a clue how this stuff is set up, I suggest you read here: https://reswitchedweekly.github.io/Building-RetroArch/ and here: https://reswitchedweekly.github.io/Development-Setup/

    And if you want to also set up the image for 3ds stuff, I HIGHLY recommend you start by using the perl script, then update ctrulib (when installing, use sudo -H make install, that goes for installing python stuff as well (sudo -H pip install pycryptodome, "sudo -H pip install git+https://github.com/TuxSH/firmtool.git", etc)). Perl script is here: https://github.com/devkitPro/installer
     
    Last edited by urherenow, Jan 14, 2018
  3. seanp2500

    seanp2500 GBAtemp Regular

    Member
    249
    74
    Jun 2, 2010
    United States
    yardie you a lifesaver tried running script and got error about recipe for target fs.squashfs failed?

    thanks urherenow i will try build ace.nro this way i had tried just typing make
     
    Last edited by seanp2500, Jan 14, 2018