up to 4.x exploitable, but lower firmware is better

Discussion in 'Switch - Hacking & Homebrew' started by blinkzane, Jan 13, 2018.

  1. VinsCool

    VinsCool Absconditus

    Member
    GBAtemp Patron
    VinsCool is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,292
    30,463
    Jan 7, 2014
    Canada
    Another World
    Remove the internet connection?
     
  2. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    23,398
    11,316
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    Either blacklist the device (MAC filtering), removing all WiFi settings on the console?
     
  3. pinkupi13

    pinkupi13 Advanced Member

    Newcomer
    89
    3
    May 8, 2016
    Australia
    of course i knew there'd be something more beyond 3.0. SciresM had been hinting towards having done things with odyssey for a long time darnit and those hints were for all to see.
    All just an excuse just to attention-seek and not release anything for more weeks.
    yes i know it could get patched but that might happen anyway even without spreading word.
     
  4. TheCyberQuake

    TheCyberQuake Certified Geek

    Member
    3,638
    2,456
    Dec 2, 2014
    United States
    Las Vegas, Nevada
    You do realize they do that in order to keep the vulnerability in as many firmwares as possible. Keeping it secret benefits the community long term as it opens up more firmwares. It also allows users to benefit from features in newer firmwares while still having vulns exist for homebrew.
     
  5. TheCyberQuake

    TheCyberQuake Certified Geek

    Member
    3,638
    2,456
    Dec 2, 2014
    United States
    Las Vegas, Nevada
    But why guarantee it be closed off if you can potentially keep it open allowing it to work on later firmwares
     
  6. Natehaxx

    Natehaxx GBAtemp Regular

    Member
    148
    91
    Jul 26, 2017
    Eritrea
    Not only that Kernelhax will also work on 3.0 Confirmed by ScriesM
     
  7. Hondyn

    Hondyn Member

    Newcomer
    47
    7
    Jan 2, 2018
    Angola
    Yes, The switch auto updates itself. Just go to settings , updates and turn the auto update off. The best thing you can do is turn the wifi off. That ll prevent your switch from any attempt of trying to update itself
     
    Last edited by Hondyn, Jan 14, 2018
  8. TheCyberQuake

    TheCyberQuake Certified Geek

    Member
    3,638
    2,456
    Dec 2, 2014
    United States
    Las Vegas, Nevada
    Or fiddler proxy to block updates
     
  9. leafeon34

    leafeon34 GBAtemp Advanced Fan

    Member
    636
    339
    Sep 30, 2014
    I should have bought a Switch earlier but that's life. 2.3 is still a good place to be.
     
  10. chartube12

    chartube12 GBAtemp Psycho!

    Member
    3,316
    530
    Mar 3, 2010
    United States
    cause they were guys who used to do work for sega n nintendo.
     
  11. pLaYeR^^

    pLaYeR^^ GBAtemp Fan

    Member
    455
    47
    Sep 18, 2014
    Austria
    You can't run CFW or EmuNand on kernel level?
     
  12. TheCyberQuake

    TheCyberQuake Certified Geek

    Member
    3,638
    2,456
    Dec 2, 2014
    United States
    Las Vegas, Nevada
    No, that requires trustzone afaik
     
    pLaYeR^^ likes this.
  13. DarthDub

    DarthDub Amateur Hacker

    Member
    1,358
    1,096
    Jan 26, 2016
    United States
    Your mom's basement.
    And having Gamecube (USB) controller support!
     
  14. TheCyberQuake

    TheCyberQuake Certified Geek

    Member
    3,638
    2,456
    Dec 2, 2014
    United States
    Las Vegas, Nevada
    Pretty sure that falls under "features in newer firmwares" but yes.
     
    DarthDub likes this.
  15. DarthDub

    DarthDub Amateur Hacker

    Member
    1,358
    1,096
    Jan 26, 2016
    United States
    Your mom's basement.
    Just wanted an excuse to quote you. Just super excited is all.
     
  16. FliP0x

    FliP0x Advanced Member

    Newcomer
    86
    18
    Aug 6, 2016
    Croatia
    Good that this has been brought up as clarification.

    People have been toxic and licking TX balls enough as is. Nobody released a product yet, so they are all on the same boat.

    Whether TX or someone else does it first doesn't matter. It's just a matter of time before the switch will be wide open.
     
    DayVeeBoi likes this.
  17. Meriadoc

    Meriadoc Advanced Member

    Newcomer
    58
    3
    May 14, 2016
    Italy
    Same. I'm sad to not have the possibility to emunand/cfw on 2.3 :C
     
  18. mech

    mech ♥️♥️♥️♥️♥️♥️♥️♥️

    Member
    5,153
    3,412
    Oct 26, 2014
    Aruba
    Give it time lol.
     
  19. shadoom

    shadoom GBAtemp Regular

    Member
    171
    69
    Sep 14, 2009
    Taiwan
    >only rls when patched
    >Nint never patches it
    >Never will get rlsd
    Winwin
     
    SnAQ and blinkzane like this.
  20. Tempest228

    Tempest228 GBAtemp Regular

    Member
    204
    110
    Jul 13, 2015
    United States
    Leave for a week and suddenly everything is happening. Unfortunate to be on 4.1, but I guess I'll stay there.