[List] Games required Firmware version

Discussion in 'Switch - Hacking & Homebrew' started by B4rtj4h, Oct 5, 2017.

  1. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    785
    198
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    So actually very simple: In this list we will put the games and their minimal installed version of a certain firmware that is needed to plat the game.
    This way you are not wasting money by buying a game that you can't play. (I had 3.0.0 and bought Pankapu and it needed to update to 3.0.2 :glare:)
    This list is for cartridge and E-shop games! Main reason from this list is now also to see what games you are missing out on when staying on a lower firmware.

    Last date updated: 19 January 2018

    Format explanation:

    :wtf: So the bad news: we do know what is going on with Zelda and Mario kart etc! There is a version 000 and a version 001 and higher cartridge. 000 is the launch version and playable on < 2.3.0 (for old games anyways) See picture for explanation.
    :!: But if you have your Switch connected to the internet it will prompt you for an update!
    :arrow: Updates are not automatically. You always are in full control. If you want to remove the update notification see below.
    :ph34r: Bonus: when there is an update on the cartridge version it will be marked after the name. :ninja:

    :switch: Help me with this list! If you know a game that is not on the list please report :)


    Firmware 4.1.0
    Firmware 4.0.1
    Firmware 4.0.0
    Firmware 3.0.2
    Firmware 3.0.1
    Firmware 3.0.0
    Firmware 2.3.0 and lower

    How to remove update notifications
     

    Attached Files:

    Last edited by B4rtj4h, Jan 19, 2018 at 2:16 PM
  2. thurp

    thurp Member

    Newcomer
    10
    4
    Jul 9, 2017
    Australia
    If i remember right Splatoon 2 needs 3.0.0
     
  3. linuxares

    linuxares GBAtemp Psycho!

    Member
    3,461
    1,554
    Aug 5, 2007
    Wait what? Isn't that a 1.0 game?
     
    B4rtj4h likes this.
  4. DarkIrata

    DarkIrata GBAtemp Fan

    Member
    435
    226
    Jun 12, 2015
    Gambia, The
    Zelda Breath of the Wild, 3.0 ? Nope ?
     
    MeAndHax and B4rtj4h like this.
  5. joseph0042

    joseph0042 GBAtemp Regular

    Member
    143
    35
    Nov 5, 2012
    United States
    Yeah ZBOTW is 1.0...

    Edit: I believe that Pokken Tournament DX is 3.0, as other people were asking which cart to buy to upgrade to 3.0 and it was listed.
     
    Last edited by joseph0042, Oct 5, 2017
    B4rtj4h likes this.
  6. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    785
    198
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    You're right! Thnx :) Also added Stardew Valley.
     
    DarkIrata likes this.
  7. mech

    mech ♥️♥️♥️♥️♥️♥️♥️♥️

    Member
    5,153
    3,412
    Oct 26, 2014
    Aruba
    Splatoon 2 is 2.3.0 not 3.0.0

    — Posts automatically merged - Please don't double post! —

    Pokken tournament is 3.0.0
     
    B4rtj4h likes this.
  8. Kawaii

    Kawaii GBAtemp Regular

    Member
    286
    128
    Apr 30, 2015
    New Zealand
    Not near you
    This list should really be just for physical game. To my knowledge any eshop games/update/dlc new or old that is for purchase or download today from eshop will require update to access the eshop
     
  9. voddy

    voddy No Title Available

    Member
    299
    91
    Jul 14, 2013
    United States
    2.3 and lower:
    Xenoverse 2
    Bomberman
     
    B4rtj4h likes this.
  10. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    785
    198
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    That's not true. I had 3.0.0 and could go in to the E-shop without installing any update. But to play Pankapu it needed to install the update.
    And there is a way to install game updates without updating the Switch itself!
     
    Last edited by B4rtj4h, Oct 5, 2017
  11. Kawaii

    Kawaii GBAtemp Regular

    Member
    286
    128
    Apr 30, 2015
    New Zealand
    Not near you
    This says otherwise. https://gbatemp.net/threads/switch-updating-faq.481266/
    You can link a post on how to do so. It would help a lot of people updating games with updating firmware
     
    acidmango and B4rtj4h like this.
  12. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,804
    5,684
    Mar 17, 2010
    Norway
    Alola
    Project Octopath demo requires 3.0.2 so don't even bother downloading it unless you're willing to update.
    Same, I was on 3.0.1 and could access eShop and download Octopath but when I tried to actually run it it told me it needed a firmware update to run.
    I expect it won't be long before Nintendo updates the version check to require the latest firmware to access anything though. They usually don't update the check right away, so they're probably just giving people with bad internet some time before they are required to update.
     
  13. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    785
    198
    Apr 16, 2007
    Netherlands
    Bikini Bottom
  14. peteruk

    peteruk GBAtemp Advanced Maniac

    Member
    1,571
    765
    Jun 26, 2015
    FIFA requires 3.01
     
    B4rtj4h likes this.
  15. leafeon34

    leafeon34 GBAtemp Advanced Fan

    Member
    636
    339
    Sep 30, 2014
    Mario VS Rabbids Kingdom is 2.3.
     
    B4rtj4h likes this.
  16. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    785
    198
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    Thnx for the update! I noticed that when you update games they won't check for the newest Firmware...
     
  17. acidmango

    acidmango GBAtemp Regular

    Member
    106
    47
    Nov 8, 2014
    Canada
  18. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    785
    198
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    It does 2 weeks ago. There I updated Snipper Clips without the need for a system update.
     
  19. leafeon34

    leafeon34 GBAtemp Advanced Fan

    Member
    636
    339
    Sep 30, 2014
    I just tried it now with Mario Kart 8 and have gotten error code 2016-1100 twice. "A system update is required to download this data."
     
    Last edited by leafeon34, Oct 10, 2017
  20. Kawaii

    Kawaii GBAtemp Regular

    Member
    286
    128
    Apr 30, 2015
    New Zealand
    Not near you
    Snipperclips dosent have update? Mine is still version 1.0 on fw 3.0.2
     
    acidmango likes this.